Hubstaff Requirements Mac OS X

Hubstaff Requirements Mac OS X

Question:

What version of Mac OS X do I need to use Hubstaff?

Answer:

Currently, we are only supporting OS X 10.6.8 or newer.

Several pieces of functionality won’t work on 10.5 at this time so it most likely won’t be supported in the future either. Every Intel-based Mac can run at least 10.6.8, only the PPC macs can’t upgrade to Snow Leopard and we won’t be building a PPC version at all.

Read more about upgrading to OS X 10.6.8.

  • Was this Helpful ?
  • Yes   No
  • Was this Helpful ?
  • Yes   No